Class: PEM::DependencyChecker

Inherits:
Object
  • Object
show all
Defined in:
lib/pem/dependency_checker.rb

Class Method Summary collapse

Class Method Details

.check_dependenciesObject


3
4
5
6
# File 'lib/pem/dependency_checker.rb', line 3

def self.check_dependencies
  return if Helper.is_test?
  self.check_xcode_select
end

.check_xcode_selectObject


8
9
10
11
12
13
14
15
16
17
# File 'lib/pem/dependency_checker.rb', line 8

def self.check_xcode_select
  unless `xcode-select -v`.include?"xcode-select version "
    Helper.log.fatal '#############################################################'
    Helper.log.fatal "# You have to install the Xcode commdand line tools to use PEM"
    Helper.log.fatal "# Install the latest version of Xcode from the AppStore"
    Helper.log.fatal "# Run xcode-select --install to install the developer tools"
    Helper.log.fatal '#############################################################'
    raise "Run 'xcode-select --install' and start PEM again"
  end
end