Class: Pay::Engine

Inherits:
Rails::Engine
  • Object
show all
Defined in:
lib/pay/engine.rb

Instance Method Summary collapse

Instance Method Details

#version_matches?(current:, required:) ⇒ Boolean

Determines if a gem version matches requirements Used for verifying that dependencies are correct

Returns:

  • (Boolean)

42
43
44
# File 'lib/pay/engine.rb', line 42

def version_matches?(current:, required:)
  Gem::Dependency.new("gem", required).match? "gem", current
end