Class: OpenSSL::PKCS7::PKCS7

Inherits:
OpenSSL::PKCS7 show all
Defined in:
lib/jopenssl18/openssl/pkcs7.rb

Overview

This class is only provided for backwards compatibility. Use OpenSSL::PKCS7 in the future.

Instance Method Summary collapse

Constructor Details

#initialize(*args) ⇒ PKCS7

Returns a new instance of PKCS7.


16
17
18
19
20
# File 'lib/jopenssl18/openssl/pkcs7.rb', line 16

def initialize(*args)
  super(*args)

  warn("Warning: OpenSSL::PKCS7::PKCS7 is deprecated after Ruby 1.9; use OpenSSL::PKCS7 instead")
end