Module: Fastlane::Helper::XcversionHelper::Verify

Defined in:
fastlane/lib/fastlane/helper/xcversion_helper.rb

Class Method Summary collapse

Class Method Details

.requirement(req) ⇒ Object


16
17
18
19
20
21
# File 'fastlane/lib/fastlane/helper/xcversion_helper.rb', line 16

def self.requirement(req)
  UI.user_error!("Version must be specified") if req.nil? || req.to_s.strip.size == 0
  Gem::Requirement.new(req.to_s)
rescue Gem::Requirement::BadRequirementError
  UI.user_error!("The requirement '#{req}' is not a valid RubyGems style requirement")
end