Class: Bundler::EndpointSpecification

Inherits:
Gem::Specification show all
Includes:
MatchPlatform
Defined in:
lib/bundler/endpoint_specification.rb

Overview

used for Creating Specifications from the Gemcutter Endpoint

Constant Summary

Constants included from GemHelpers

GemHelpers::GENERICS, GemHelpers::GENERIC_CACHE

Constants inherited from Gem::Specification

Gem::Specification::LATEST_RUBY_WITHOUT_PATCH_VERSIONS

Instance Attribute Summary collapse

Attributes inherited from Gem::Specification

#location, #relative_loaded_from

Instance Method Summary collapse

Methods included from MatchPlatform

#match_platform, platforms_match?

Methods included from GemHelpers

generic, generic_local_platform, local_platform, platform_specificity_match, same_deps, same_specificity, select_best_platform_match

Methods inherited from Gem::Specification

#deleted_gem?, #extension_dir, #full_gem_path, #gem_dir, #git_version, #groups, #loaded_from, #nondevelopment_dependencies, #required_ruby_version=, #rg_extension_dir, #rg_full_gem_path, #rg_loaded_from, #rg_required_ruby_version=, #to_gemfile

Methods included from Gem::Specification::YamlBackfiller

#to_yaml

Constructor Details

#initialize(name, version, platform, spec_fetcher, dependencies, metadata = nil) ⇒ EndpointSpecification

Returns a new instance of EndpointSpecification.


11
12
13
14
15
16
17
18
19
20
21
22
23
# File 'lib/bundler/endpoint_specification.rb', line 11

def initialize(name, version, platform, spec_fetcher, dependencies,  = nil)
  super()
  @name         = name
  @version      = Gem::Version.create version
  @platform     = platform
  @spec_fetcher = spec_fetcher
  @dependencies = dependencies.map {|dep, reqs| build_dependency(dep, reqs) }

  @loaded_from          = nil
  @remote_specification = nil

  ()
end

Instance Attribute Details

#checksumObject (readonly)

Returns the value of attribute checksum.


8
9
10
# File 'lib/bundler/endpoint_specification.rb', line 8

def checksum
  @checksum
end

#dependenciesObject

Returns the value of attribute dependencies.


9
10
11
# File 'lib/bundler/endpoint_specification.rb', line 9

def dependencies
  @dependencies
end

#nameObject (readonly)

Returns the value of attribute name.


8
9
10
# File 'lib/bundler/endpoint_specification.rb', line 8

def name
  @name
end

#platformObject (readonly)

Returns the value of attribute platform.


8
9
10
# File 'lib/bundler/endpoint_specification.rb', line 8

def platform
  @platform
end

#remoteObject

Returns the value of attribute remote.


9
10
11
# File 'lib/bundler/endpoint_specification.rb', line 9

def remote
  @remote
end

#sourceObject

Returns the value of attribute source.


9
10
11
# File 'lib/bundler/endpoint_specification.rb', line 9

def source
  @source
end

#versionObject (readonly)

Returns the value of attribute version.


8
9
10
# File 'lib/bundler/endpoint_specification.rb', line 8

def version
  @version
end

Instance Method Details

#__swap__(spec) ⇒ Object


113
114
115
116
# File 'lib/bundler/endpoint_specification.rb', line 113

def __swap__(spec)
  SharedHelpers.ensure_same_dependencies(self, dependencies, spec.dependencies)
  @remote_specification = spec
end

#_local_specificationObject


106
107
108
109
110
111
# File 'lib/bundler/endpoint_specification.rb', line 106

def _local_specification
  return unless @loaded_from && File.exist?(local_specification_path)
  eval(File.read(local_specification_path)).tap do |spec|
    spec.loaded_from = @loaded_from
  end
end

#bindirObject

needed for bundle clean


74
75
76
77
78
79
80
81
82
# File 'lib/bundler/endpoint_specification.rb', line 74

def bindir
  if @remote_specification
    @remote_specification.bindir
  elsif _local_specification
    _local_specification.bindir
  else
    super
  end
end

#executablesObject

needed for binstubs


63
64
65
66
67
68
69
70
71
# File 'lib/bundler/endpoint_specification.rb', line 63

def executables
  if @remote_specification
    @remote_specification.executables
  elsif _local_specification
    _local_specification.executables
  else
    super
  end
end

#extensionsObject

needed for “with native extensions” during install


96
97
98
99
100
101
102
103
104
# File 'lib/bundler/endpoint_specification.rb', line 96

def extensions
  if @remote_specification
    @remote_specification.extensions
  elsif _local_specification
    _local_specification.extensions
  else
    super
  end
end

#fetch_platformObject


36
37
38
# File 'lib/bundler/endpoint_specification.rb', line 36

def fetch_platform
  @platform
end

#load_pathsObject

needed for inline


53
54
55
56
57
58
59
60
# File 'lib/bundler/endpoint_specification.rb', line 53

def load_paths
  # remote specs aren't installed, and can't have load_paths
  if _local_specification
    _local_specification.load_paths
  else
    super
  end
end

#post_install_messageObject

needed for post_install_messages during install


85
86
87
88
89
90
91
92
93
# File 'lib/bundler/endpoint_specification.rb', line 85

def post_install_message
  if @remote_specification
    @remote_specification.post_install_message
  elsif _local_specification
    _local_specification.post_install_message
  else
    super
  end
end

#require_pathsObject

needed for standalone, load required_paths from local gemspec after the gem is installed


42
43
44
45
46
47
48
49
50
# File 'lib/bundler/endpoint_specification.rb', line 42

def require_paths
  if @remote_specification
    @remote_specification.require_paths
  elsif _local_specification
    _local_specification.require_paths
  else
    super
  end
end

#required_ruby_versionObject


25
26
27
# File 'lib/bundler/endpoint_specification.rb', line 25

def required_ruby_version
  @required_ruby_version ||= _remote_specification.required_ruby_version
end

#required_rubygems_versionObject

A fallback is included because the original version of the specification API didn't include that field, so some marshalled specs in the index have it set to nil.


32
33
34
# File 'lib/bundler/endpoint_specification.rb', line 32

def required_rubygems_version
  @required_rubygems_version ||= _remote_specification.required_rubygems_version || Gem::Requirement.default
end