Class: Aws::EKS::Types::UpdateNodegroupVersionRequest

Inherits:
Struct
  • Object
show all
Includes:
Structure
Defined in:
lib/aws-sdk-eks/types.rb

Overview

Note:

When making an API call, you may pass UpdateNodegroupVersionRequest data as a hash:

{
  cluster_name: "String", # required
  nodegroup_name: "String", # required
  version: "String",
  release_version: "String",
  launch_template: {
    name: "String",
    version: "String",
    id: "String",
  },
  force: false,
  client_request_token: "String",
}

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#client_request_tokenString

Unique, case-sensitive identifier that you provide to ensure the idempotency of the request.

**A suitable default value is auto-generated.** You should normally not need to pass this option.

Returns:

  • (String)

3937
3938
3939
3940
3941
3942
3943
3944
3945
3946
3947
# File 'lib/aws-sdk-eks/types.rb', line 3937

class UpdateNodegroupVersionRequest < Struct.new(
  :cluster_name,
  :nodegroup_name,
  :version,
  :release_version,
  :launch_template,
  :force,
  :client_request_token)
  SENSITIVE = []
  include Aws::Structure
end

#cluster_nameString

The name of the Amazon EKS cluster that is associated with the managed node group to update.

Returns:

  • (String)

3937
3938
3939
3940
3941
3942
3943
3944
3945
3946
3947
# File 'lib/aws-sdk-eks/types.rb', line 3937

class UpdateNodegroupVersionRequest < Struct.new(
  :cluster_name,
  :nodegroup_name,
  :version,
  :release_version,
  :launch_template,
  :force,
  :client_request_token)
  SENSITIVE = []
  include Aws::Structure
end

#forceBoolean

Force the update if the existing node group's pods are unable to be drained due to a pod disruption budget issue. If an update fails because pods could not be drained, you can force the update after it fails to terminate the old node whether or not any pods are running on the node.

Returns:

  • (Boolean)

3937
3938
3939
3940
3941
3942
3943
3944
3945
3946
3947
# File 'lib/aws-sdk-eks/types.rb', line 3937

class UpdateNodegroupVersionRequest < Struct.new(
  :cluster_name,
  :nodegroup_name,
  :version,
  :release_version,
  :launch_template,
  :force,
  :client_request_token)
  SENSITIVE = []
  include Aws::Structure
end

#launch_templateTypes::LaunchTemplateSpecification

An object representing a node group's launch template specification. You can only update a node group using a launch template if the node group was originally deployed with a launch template.


3937
3938
3939
3940
3941
3942
3943
3944
3945
3946
3947
# File 'lib/aws-sdk-eks/types.rb', line 3937

class UpdateNodegroupVersionRequest < Struct.new(
  :cluster_name,
  :nodegroup_name,
  :version,
  :release_version,
  :launch_template,
  :force,
  :client_request_token)
  SENSITIVE = []
  include Aws::Structure
end

#nodegroup_nameString

The name of the managed node group to update.

Returns:

  • (String)

3937
3938
3939
3940
3941
3942
3943
3944
3945
3946
3947
# File 'lib/aws-sdk-eks/types.rb', line 3937

class UpdateNodegroupVersionRequest < Struct.new(
  :cluster_name,
  :nodegroup_name,
  :version,
  :release_version,
  :launch_template,
  :force,
  :client_request_token)
  SENSITIVE = []
  include Aws::Structure
end

#release_versionString

The AMI version of the Amazon EKS optimized AMI to use for the update. By default, the latest available AMI version for the node group's Kubernetes version is used. For more information, see

Amazon EKS optimized Amazon Linux 2 AMI versions ][1

in the

*Amazon EKS User Guide*. If you specify `launchTemplate`, and your launch template uses a custom AMI, then don't specify `releaseVersion`, or the node group update will fail. For more information about using launch templates with Amazon EKS, see

Launch template support][2

in the Amazon EKS User Guide.

[1]: docs.aws.amazon.com/eks/latest/userguide/eks-linux-ami-versions.html [2]: docs.aws.amazon.com/eks/latest/userguide/launch-templates.html

Returns:

  • (String)

3937
3938
3939
3940
3941
3942
3943
3944
3945
3946
3947
# File 'lib/aws-sdk-eks/types.rb', line 3937

class UpdateNodegroupVersionRequest < Struct.new(
  :cluster_name,
  :nodegroup_name,
  :version,
  :release_version,
  :launch_template,
  :force,
  :client_request_token)
  SENSITIVE = []
  include Aws::Structure
end

#versionString

The Kubernetes version to update to. If no version is specified, then the Kubernetes version of the node group does not change. You can specify the Kubernetes version of the cluster to update the node group to the latest AMI version of the cluster's Kubernetes version. If you specify `launchTemplate`, and your launch template uses a custom AMI, then don't specify `version`, or the node group update will fail. For more information about using launch templates with Amazon EKS, see [Launch template support] in the Amazon EKS User Guide.

[1]: docs.aws.amazon.com/eks/latest/userguide/launch-templates.html

Returns:

  • (String)

3937
3938
3939
3940
3941
3942
3943
3944
3945
3946
3947
# File 'lib/aws-sdk-eks/types.rb', line 3937

class UpdateNodegroupVersionRequest < Struct.new(
  :cluster_name,
  :nodegroup_name,
  :version,
  :release_version,
  :launch_template,
  :force,
  :client_request_token)
  SENSITIVE = []
  include Aws::Structure
end