Class: Chef::Provider::Package::Solaris

Inherits:
Chef::Provider::Package show all
Includes:
Mixin::GetSourceFromPackage
Defined in:
lib/chef/provider/package/solaris.rb

Instance Attribute Summary

Attributes inherited from Chef::Provider

#action, #current_resource, #logger, #new_resource, #recipe_name, #run_context

Instance Method Summary collapse

Methods included from Mixin::GetSourceFromPackage

#initialize

Methods inherited from Chef::Provider::Package

#action_lock, #action_unlock, #as_array, #check_resource_semantics!, #expand_options, #have_any_matching_version?, #initialize, #lock_package, #multipackage_api_adapter, #options, #package_locked, #prepare_for_installation, #preseed_package, #purge_package, #reconfig_package, #removing_package?, #target_version_already_installed?, #unlock_package, #version_compare, #version_equals?, #version_requirement_satisfied?

Methods included from Mixin::SubclassDirective

#subclass_directive

Methods included from Mixin::ShellOut

apply_default_env, maybe_add_timeout, #shell_out, #shell_out!

Methods inherited from Chef::Provider

action, #action_nothing, #check_resource_semantics!, #cleanup_after_converge, #compile_and_converge_action, #converge_by, #converge_if_changed, #cookbook_name, #description, #events, include_resource_dsl?, include_resource_dsl_module, #initialize, #introduced, #node, #process_resource_requirements, provides, provides?, #requirements, #resource_collection, #resource_updated?, #run_action, #set_updated_status, supports?, use_inline_resources, #whyrun_mode?, #whyrun_supported?

Methods included from Mixin::Provides

#provided_as, #provides, #provides?

Methods included from Mixin::DescendantsTracker

#descendants, descendants, direct_descendants, #direct_descendants, find_descendants_by_name, #find_descendants_by_name, #inherited, store_inherited

Methods included from Mixin::LazyModuleInclude

#descendants, #include, #included

Methods included from Mixin::PowershellOut

#powershell_out, #powershell_out!

Methods included from Mixin::WindowsArchitectureHelper

#assert_valid_windows_architecture!, #disable_wow64_file_redirection, #forced_32bit_override_required?, #is_i386_process_on_x86_64_windows?, #node_supports_windows_architecture?, #node_windows_architecture, #restore_wow64_file_redirection, #valid_windows_architecture?, #with_os_architecture, #wow64_architecture_override_required?, #wow64_directory

Methods included from Mixin::PowershellExec

#powershell_exec

Methods included from DSL::Powershell

#ps_credential

Methods included from DSL::RegistryHelper

#registry_data_exists?, #registry_get_subkeys, #registry_get_values, #registry_has_subkeys?, #registry_key_exists?, #registry_value_exists?

Methods included from DSL::DataQuery

#data_bag, #data_bag_item, #search, #tagged?

Methods included from EncryptedDataBagItem::CheckEncrypted

#encrypted?

Methods included from DSL::PlatformIntrospection

#older_than_win_2012_or_8?, #platform?, #platform_family?, #value_for_platform, #value_for_platform_family

Methods included from Mixin::NotifyingBlock

#notifying_block, #subcontext_block

Methods included from DSL::DeclareResource

#build_resource, #declare_resource, #delete_resource, #delete_resource!, #edit_resource, #edit_resource!, #find_resource, #find_resource!, #resources, #with_run_context

Instance Method Details

#candidate_versionObject



84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
# File 'lib/chef/provider/package/solaris.rb', line 84

def candidate_version
  return @candidate_version if @candidate_version

  status = shell_out("pkginfo", "-l", "-d", new_resource.source, new_resource.package_name)
  status.stdout.each_line do |line|
    case line
    when /VERSION:\s+(.+)/
      @candidate_version = $1
      new_resource.version($1)
      logger.trace("#{new_resource} setting install candidate version to #{@candidate_version}")
    end
  end
  unless status.exitstatus == 0
    raise Chef::Exceptions::Package, "pkginfo -l -d #{new_resource.source} - #{status.inspect}!"
  end

  @candidate_version
end

#define_resource_requirementsObject

def initialize(*args)

super
@current_resource = Chef::Resource::Package.new(new_resource.name)

end



37
38
39
40
41
42
43
44
45
46
47
48
# File 'lib/chef/provider/package/solaris.rb', line 37

def define_resource_requirements
  super
  requirements.assert(:install) do |a|
    a.assertion { new_resource.source }
    a.failure_message Chef::Exceptions::Package, "Source for package #{new_resource.package_name} required for action install"
  end
  requirements.assert(:all_actions) do |a|
    a.assertion { !new_resource.source || @package_source_found }
    a.failure_message Chef::Exceptions::Package, "Package #{new_resource.package_name} not found: #{new_resource.source}"
    a.whyrun "would assume #{new_resource.source} would be have previously been made available"
  end
end

#install_package(name, version) ⇒ Object Also known as: upgrade_package



103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
# File 'lib/chef/provider/package/solaris.rb', line 103

def install_package(name, version)
  logger.trace("#{new_resource} package install options: #{options}")
  if options.nil?
    command = if ::File.directory?(new_resource.source) # CHEF-4469
                [ "pkgadd", "-n", "-d", new_resource.source, new_resource.package_name ]
              else
                [ "pkgadd", "-n", "-d", new_resource.source, "all" ]
              end
    shell_out!(command)
    logger.trace("#{new_resource} installed version #{new_resource.version} from: #{new_resource.source}")
  else
    command = if ::File.directory?(new_resource.source) # CHEF-4469
                [ "pkgadd", "-n", options, "-d", new_resource.source, new_resource.package_name ]
              else
                [ "pkgadd", "-n", options, "-d", new_resource.source, "all" ]
              end
    shell_out!(*command)
    logger.trace("#{new_resource} installed version #{new_resource.version} from: #{new_resource.source}")
  end
end

#load_current_resourceObject



50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
# File 'lib/chef/provider/package/solaris.rb', line 50

def load_current_resource
  @current_resource = Chef::Resource::Package.new(new_resource.name)
  current_resource.package_name(new_resource.package_name)

  if new_resource.source
    @package_source_found = ::File.exist?(new_resource.source)
    if @package_source_found
      logger.trace("#{new_resource} checking pkg status")
      shell_out("pkginfo", "-l", "-d", new_resource.source, new_resource.package_name).stdout.each_line do |line|
        case line
        when /VERSION:\s+(.+)/
          new_resource.version($1)
        end
      end
    end
  end

  logger.trace("#{new_resource} checking install state")
  status = shell_out("pkginfo", "-l", current_resource.package_name)
  status.stdout.each_line do |line|
    case line
    when /VERSION:\s+(.+)/
      logger.trace("#{new_resource} version #{$1} is already installed")
      current_resource.version($1)
    end
  end

  unless status.exitstatus == 0 || status.exitstatus == 1
    raise Chef::Exceptions::Package, "pkginfo failed - #{status.inspect}!"
  end

  current_resource
end

#remove_package(name, version) ⇒ Object



126
127
128
129
130
131
132
133
134
# File 'lib/chef/provider/package/solaris.rb', line 126

def remove_package(name, version)
  if options.nil?
    shell_out!( "pkgrm", "-n", name )
    logger.trace("#{new_resource} removed version #{new_resource.version}")
  else
    shell_out!( "pkgrm", "-n", options, name )
    logger.trace("#{new_resource} removed version #{new_resource.version}")
  end
end