Module: Flo

Defined in:
lib/flo.rb,
lib/flo/cli.rb,
lib/flo/task.rb,
lib/flo/error.rb,
lib/flo/state.rb,
lib/flo/config.rb,
lib/flo/runner.rb,
lib/flo/command.rb,
lib/flo/version.rb,
lib/flo/provider/base.rb,
lib/flo/cred_store/creds.rb,
lib/flo/command_collection.rb,
lib/flo/provider/developer.rb,
lib/flo/cred_store/yaml_store.rb,
lib/flo/cred_store/pw_protected_store.rb

Overview

Copyright © 2017, Salesforce.com, Inc. All Rights Reserved. Licensed under the BSD 3-Clause license. For full license text, see LICENSE.txt file in the repo root or opensource.org/licenses/BSD-3-Clause

Defined Under Namespace

Modules: CredStore, Provider Classes: Cli, Command, CommandCollection, Config, Runner, State, Task

Constant Summary collapse

Error =
Class.new(StandardError)
MissingRequireError =
Class.new(Flo::Error)
VERSION =
"0.0.4"
MissingCredentialError =
Class.new(Flo::Error)
CommandNotDefinedError =
Class.new(Flo::Error)
MissingProviderError =
Class.new(Flo::Error)