Exception: Gem::Resolver::Molinillo::VersionConflict

Inherits:
ResolverError
  • Object
show all
Defined in:
lib/rubygems/resolver/molinillo/lib/molinillo/errors.rb

Overview

An error caused by conflicts in version

Instance Attribute Summary collapse

Instance Method Summary collapse

Constructor Details

#initialize(conflicts) ⇒ VersionConflict

Initializes a new error with the given version conflicts.

Parameters:

  • conflicts ({String => Resolution::Conflict})

60
61
62
63
64
65
66
67
68
69
70
71
72
73
# File 'lib/rubygems/resolver/molinillo/lib/molinillo/errors.rb', line 60

def initialize(conflicts)
  pairs = []
  conflicts.values.flatten.map(&:requirements).flatten.each do |conflicting|
    conflicting.each do |source, conflict_requirements|
      conflict_requirements.each do |c|
        pairs << [c, source]
      end
    end
  end

  super "Unable to satisfy the following requirements:\n\n" \
    "#{pairs.map { |r, d| "- `#{r}` required by `#{d}`" }.join("\n")}"
  @conflicts = conflicts
end

Instance Attribute Details

#conflicts{String => Resolution::Conflict} (readonly)

Returns the conflicts that caused resolution to fail.

Returns:

  • ({String => Resolution::Conflict})

    the conflicts that caused resolution to fail


56
57
58
# File 'lib/rubygems/resolver/molinillo/lib/molinillo/errors.rb', line 56

def conflicts
  @conflicts
end