Module: Lunanode

Defined in:
lib/lunanode.rb,
lib/lunanode/api.rb,
lib/lunanode/version.rb,
lib/lunanode/api_error.rb,
lib/lunanode/api_actions.rb,
lib/lunanode/api_actions/lb.rb,
lib/lunanode/api_actions/vm.rb,
lib/lunanode/api_actions/dns.rb,
lib/lunanode/api_actions/plan.rb,
lib/lunanode/api_actions/email.rb,
lib/lunanode/api_actions/image.rb,
lib/lunanode/api_actions/region.rb,
lib/lunanode/api_actions/script.rb,
lib/lunanode/api_actions/volume.rb,
lib/lunanode/api_actions/monitor.rb,
lib/lunanode/api_actions/network.rb,
lib/lunanode/api_actions/floating.rb,
lib/lunanode/api_actions/default/lb.rb,
lib/lunanode/api_actions/default/vm.rb,
lib/lunanode/api_actions/default/dns.rb,
lib/lunanode/api_actions/default/plan.rb,
lib/lunanode/api_actions/default/email.rb,
lib/lunanode/api_actions/default/image.rb,
lib/lunanode/api_actions/securitygroup.rb,
lib/lunanode/api_actions/default/region.rb,
lib/lunanode/api_actions/default/script.rb,
lib/lunanode/api_actions/default/volume.rb,
lib/lunanode/api_actions/default/monitor.rb,
lib/lunanode/api_actions/default/network.rb,
lib/lunanode/api_actions/default/floating.rb,
lib/lunanode/api_actions/default/securitygroup.rb

Overview

Namespace for classes and modules in the Lunanode API gem

See API for usage information.

Defined Under Namespace

Modules: APIActions Classes: API, APIError

Constant Summary collapse

VERSION =
"0.2.0".freeze