Module: SonyCameraRemoteAPI

Defined in:
lib/sony_camera_remote_api.rb,
lib/sony_camera_remote_api/ssdp.rb,
lib/sony_camera_remote_api/error.rb,
lib/sony_camera_remote_api/utils.rb,
lib/sony_camera_remote_api/shelf.rb,
lib/sony_camera_remote_api/packet.rb,
lib/sony_camera_remote_api/scripts.rb,
lib/sony_camera_remote_api/version.rb,
lib/sony_camera_remote_api/raw_api.rb,
lib/sony_camera_remote_api/camera_api.rb,
lib/sony_camera_remote_api/client/main.rb,
lib/sony_camera_remote_api/client/shelf.rb,
lib/sony_camera_remote_api/camera_api_group.rb,
lib/sony_camera_remote_api/camera_api_group_def.rb

Defined Under Namespace

Modules: Client, SSDP, Scripts, Utils Classes: APIExecutionError, APIForbidden, APINotAvailable, APINotSupported, APIVersionInvalid, Camera, CameraAPIGroupManager, CameraAPIManager, DataVersion, EventTimeoutError, IllegalArgument, LiveviewFrameInformation, LiveviewFrameInformationPayload, LiveviewImage, LiveviewImagePayload, LiveviewPacket, Point, RawAPIManager, ServerNotCompatible, ServiceTypeInvalid, ServiceTypeNotGiven, Shelf, StandardErrorWithObj

Constant Summary collapse

VERSION =

Version

'0.2.2'.freeze