Warhol

Gem Version Build Status Dependency Status Code Climate

A Ruby client gem for the Canvas LMS API.

Installation

Add this line to your application's Gemfile:

gem 'warhol'

And then execute:

$ bundle

Or install it yourself as:

$ gem install warhol

Getting started

TODO: Write usage instructions here

Documentation

http://rdoc.info/gems/warhol

Supported Ruby Versions

This library aims to support, and is tested against the following Ruby implementations:

  • Ruby 1.9.3
  • Ruby 2.0.0

Development is primarily done in a Ruby 1.9.3 environment with the latest patch release.

Versioning

This library aims to adhere to Semantic Versioning 2.0.0. Violations of this scheme should be reported as bugs. Specifically, if a minor or patch version is released that breaks backward compatibility, that version should be immediately yanked and/or a new version should be immediately released that restores compatibility. Breaking changes to the public API will only be introduced with new major versions. As a result of this policy, you can (and should) specify a dependency on this gem using the Pessimistic Version Constraint with two digits of precision. For example:

spec.add_dependency 'twitter', '~> 4.0'

Thanks

  • Special thanks to the authors of the twitter gem, from which a good deal of this gem's boilerplate and foundation is based on.

Copyright

Copyright (c) 2013 Quad Learning, Inc.

See LICENSE for details.