Ruby/ActiveLdap – ruby library for object-oriented LDAP interction Copyright (C) 2004-2006 Will Drewry <[email protected]>, Kouhei Sutou <[email protected]> Contributors:

* Dick Davies <[email protected]>
* Nathan Kinder <[email protected]>
* Patrick Cole <[email protected]>
* Google Inc.

DESCRIPTION 'Ruby/ActiveLdap' is a ruby extension library which provides a clean objected oriented interface to the Ruby/LDAP library. It was inspired by ActivRecord. This is not nearly as clean or as flexible as ActiveRecord, but it is still trivial to define new objects and manipulate them with minimal difficulty.

For example and usage - read the rdoc in doc/ from lib/activeldap.rb. It is also available on the web at:

ruby-activeldap.rubyforge.org/

PREREQUISITES

* Ruby 1.8.x [1]
* Ruby/LDAP [0]
* Log4r [4]
* ActiveRecord [2]
* (Optional) Ruby/LDAP+GSSAPI [3]
* An LDAP server compatible with Ruby/LDAP: OpenLDAP, etc

NOTES

* Only GSSAPI SASL support exists due to Ruby/LDAP limitations
* The API is subject to change as this package slowly approaches 1.0.0

INSTALL

- Edit active_ldap/configuration.rb with your LDAP preferences
- Run -
  sudo rake install

LICENCE

This program is free software; you can redistribute it and/or modify it. It is dual licensed under Ruby's license and under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2, or (at your option) any later version.

Please see the file LICENSE for the terms of the licence.

REFERENCES

0
1
2
3
4