Module: MultiJson

Extended by:
MultiJson
Includes:
Options
Included in:
MultiJson
Defined in:
lib/multi_json/vendor/okjson.rb,
lib/multi_json.rb,
lib/multi_json/adapter.rb,
lib/multi_json/options.rb,
lib/multi_json/version.rb,
lib/multi_json/adapters/oj.rb,
lib/multi_json/adapters/gson.rb,
lib/multi_json/adapters/yajl.rb,
lib/multi_json/adapters/ok_json.rb,
lib/multi_json/adapters/json_gem.rb,
lib/multi_json/adapters/json_pure.rb,
lib/multi_json/adapters/jr_jackson.rb,
lib/multi_json/adapters/json_common.rb,
lib/multi_json/convertible_hash_keys.rb,
lib/multi_json/adapters/nsjsonserialization.rb

Overview

Defined Under Namespace

Modules: Adapters, ConvertibleHashKeys, OkJson, Options Classes: Adapter, LoadError

Constant Summary collapse

DecodeError =

Legacy support

LoadError
ALIASES =
{
  'jrjackson' => :jr_jackson
}
REQUIREMENT_MAP =
[
  ['oj',           :oj],
  ['yajl',         :yajl],
  ['json',         :json_gem],
  ['gson',         :gson],
  ['jrjackson_r',  :jr_jackson],
  ['json/pure',    :json_pure]
]
VERSION =
'1.7.2'

Instance Attribute Summary

Attributes included from Options

#dump_options, #load_options

Instance Method Summary collapse

Methods included from Options

#default_dump_options, #default_load_options

Instance Method Details

#adapterObject Also known as: engine

Get the current adapter class.


68
69
70
71
72
73
74
# File 'lib/multi_json.rb', line 68

def adapter
  return @adapter if defined?(@adapter) && @adapter

  self.use nil # load default adapter

  @adapter
end

#current_adapter(options = {}) ⇒ Object


127
128
129
130
131
132
133
# File 'lib/multi_json.rb', line 127

def current_adapter(options={})
  if new_adapter = options[:adapter]
    load_adapter(new_adapter)
  else
    adapter
  end
end

#default_adapterObject Also known as: default_engine

The default adapter based on what you currently have loaded and installed. First checks to see if any adapters are already loaded, then checks to see which are installed if none are loaded.


47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
# File 'lib/multi_json.rb', line 47

def default_adapter
  return :oj if defined?(::Oj)
  return :yajl if defined?(::Yajl)
  return :json_gem if defined?(::JSON)
  return :gson if defined?(::Gson)

  REQUIREMENT_MAP.each do |(library, adapter)|
    begin
      require library
      return adapter
    rescue ::LoadError
      next
    end
  end

  Kernel.warn '[WARNING] MultiJson is using the default adapter (ok_json). We recommend loading a different JSON library to improve performance.'
  :ok_json
end

#default_options=(value) ⇒ Object


23
24
25
26
27
28
# File 'lib/multi_json.rb', line 23

def default_options=(value)
  Kernel.warn "MultiJson.default_options setter is deprecated\n" +
    "Use MultiJson.load_options and MultiJson.dump_options instead"

  self.load_options = self.dump_options = value
end

#dump(object, options = {}) ⇒ Object Also known as: encode

Encodes a Ruby object as JSON.


136
137
138
# File 'lib/multi_json.rb', line 136

def dump(object, options={})
  current_adapter(options).dump(object, options)
end

#load(string, options = {}) ⇒ Object Also known as: decode

Decode a JSON string into Ruby.

Options

:symbolize_keys :: If true, will use symbols instead of strings for the keys. :adapter :: If set, the selected adapter will be used for this call.


117
118
119
120
121
122
123
124
# File 'lib/multi_json.rb', line 117

def load(string, options={})
  adapter = current_adapter(options)
  begin
    adapter.load(string, options)
  rescue adapter::ParseError => exception
    raise LoadError.new(exception.message, exception.backtrace, string)
  end
end

#load_adapter(new_adapter) ⇒ Object


93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
# File 'lib/multi_json.rb', line 93

def load_adapter(new_adapter)
  case new_adapter
  when String, Symbol
    new_adapter = ALIASES.fetch(new_adapter.to_s, new_adapter)
    require "multi_json/adapters/#{new_adapter}"
    klass_name = new_adapter.to_s.split('_').map(&:capitalize) * ''
    MultiJson::Adapters.const_get(klass_name)
  when NilClass, FalseClass
    load_adapter default_adapter
  when Class, Module
    new_adapter
  else
    raise NameError
  end
rescue NameError, ::LoadError
  raise ArgumentError, 'Did not recognize your adapter specification.'
end

#use(new_adapter) ⇒ Object Also known as: adapter=, engine=

Set the JSON parser utilizing a symbol, string, or class. Supported by default are:

  • :oj
  • :json_gem
  • :json_pure
  • :ok_json
  • :yajl
  • :nsjsonserialization (MacRuby only)
  • :gson (JRuby only)

87
88
89
# File 'lib/multi_json.rb', line 87

def use(new_adapter)
  @adapter = load_adapter(new_adapter)
end

#with_adapter(new_adapter) ⇒ Object Also known as: with_engine

Executes passed block using specified adapter.


142
143
144
145
146
147
# File 'lib/multi_json.rb', line 142

def with_adapter(new_adapter)
  old_adapter, self.adapter = adapter, new_adapter
  yield
ensure
  self.adapter = old_adapter
end