Insults - v0.3

A module that insults you when it feels you deserve it.

Warning

Do not use this library or even look at the source codes if you are offended by cuss words!

Installation

$ sudo gem install insults

Usage

require 'insults'

That's it! Just keep an eye on STDERR.

One-Liner Example

ruby -rinsults -e 'class Satriani; end; class Vai < Satriani; end;'

Changes

  • v0.3 (2009-02-06)

    • Insults are now Ruby 1.9 compatible.

  • v0.2 (2009-01-15)

    • Added insults.

    • Reduced code readability.

    • Now 12% funnier.

  • v0.1 (2009-01-14)

    • Initial, insulting release.

More Info

Credits

  • Delano Mandelbaum (delano@solutious.com)

  • Alex Trebek (dj@solutious.com)

Thanks

  • Creston Farms (R.I.P.)

  • Hidi

License

See: LICENSE.txt