Class: Dependabot::GitSubmodules::UpdateChecker

Inherits:
UpdateCheckers::Base
  • Object
show all
Defined in:
lib/dependabot/git_submodules/update_checker.rb

Instance Method Summary collapse

Instance Method Details

#latest_resolvable_versionObject


14
15
16
17
# File 'lib/dependabot/git_submodules/update_checker.rb', line 14

def latest_resolvable_version
  # Resolvability isn't an issue for submodules.
  latest_version
end

#latest_resolvable_version_with_no_unlockObject


19
20
21
22
# File 'lib/dependabot/git_submodules/update_checker.rb', line 19

def latest_resolvable_version_with_no_unlock
  # No concept of "unlocking" for submodules
  latest_version
end

#latest_versionObject


10
11
12
# File 'lib/dependabot/git_submodules/update_checker.rb', line 10

def latest_version
  @latest_version ||= fetch_latest_version
end

#updated_requirementsObject


24
25
26
27
28
# File 'lib/dependabot/git_submodules/update_checker.rb', line 24

def updated_requirements
  # Submodule requirements are the URL and branch to use for the
  # submodule. We never want to update either.
  dependency.requirements
end