Module: Dependabot

Defined in:
lib/dependabot/composer/version.rb,
lib/dependabot/composer/file_parser.rb,
lib/dependabot/composer/requirement.rb,
lib/dependabot/composer/file_fetcher.rb,
lib/dependabot/composer/file_updater.rb,
lib/dependabot/composer/native_helpers.rb,
lib/dependabot/composer/update_checker.rb,
lib/dependabot/composer/metadata_finder.rb,
lib/dependabot/composer/file_updater/lockfile_updater.rb,
lib/dependabot/composer/file_updater/manifest_updater.rb,
lib/dependabot/composer/update_checker/version_resolver.rb,
lib/dependabot/composer/update_checker/requirements_updater.rb,
lib/dependabot/composer/file_fetcher/path_dependency_builder.rb,
lib/dependabot/composer/update_checker/latest_version_finder.rb

Overview

PHP pre-release versions use 1.0.1-rc1 syntax, which Gem::Version converts into 1.0.1.pre.rc1. We override the `to_s` method to stop that alteration.

Defined Under Namespace

Modules: Composer