Class: Dependabot::Bundler::FileUpdater::RubyRequirementSetter

Inherits:
Object
  • Object
show all
Defined in:
lib/dependabot/bundler/file_updater/ruby_requirement_setter.rb

Defined Under Namespace

Classes: GemfileRewriter, RubyVersionNotFound

Constant Summary collapse

RUBY_VERSIONS =
%w(
  1.8.7 1.9.3 2.0.0 2.1.10 2.2.10 2.3.8 2.4.10 2.5.8 2.6.6 2.7.2 3.0.0
).freeze

Instance Attribute Summary collapse

Instance Method Summary collapse

Constructor Details

#initialize(gemspec:) ⇒ RubyRequirementSetter

Returns a new instance of RubyRequirementSetter.


18
19
20
# File 'lib/dependabot/bundler/file_updater/ruby_requirement_setter.rb', line 18

def initialize(gemspec:)
  @gemspec = gemspec
end

Instance Attribute Details

#gemspecObject (readonly)

Returns the value of attribute gemspec


16
17
18
# File 'lib/dependabot/bundler/file_updater/ruby_requirement_setter.rb', line 16

def gemspec
  @gemspec
end

Instance Method Details

#rewrite(content) ⇒ Object


22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
# File 'lib/dependabot/bundler/file_updater/ruby_requirement_setter.rb', line 22

def rewrite(content)
  return content unless gemspec_declares_ruby_requirement?

  buffer = Parser::Source::Buffer.new("(gemfile_content)")
  buffer.source = content
  ast = Parser::CurrentRuby.new.parse(buffer)

  if declares_ruby_version?(ast)
    GemfileRewriter.new(
      ruby_version: ruby_version
    ).rewrite(buffer, ast)
  else
    "ruby '#{ruby_version}'\n" + content
  end
end