Build Status Gem Version Coverage Status

Very light Ruby wrapper on caniuse data.


Add this line to your application's Gemfile:

gem 'can_i_use'

And then execute:

$ bundle

Or install it yourself as:

$ gem install can_i_use


Test user agent for support of a feature. Optionally specify minimal required type of support (:almost, :polyfill, :prefix or :disabled).'canvas') # => true'canvas', :polyfill) # => true

The caniuse data are included as a submodule from the official GitHub repo. This means this gem needs to be regularly updated in order to reflect the latest features and their implementation in browsers by running (for example) git submodule foreach git pull origin master. Pull requests are welcome.

CanIUse.updated_at # => 2016-03-11 06:44:10 UTC


  1. Fork it ( )
  2. Create your feature branch (git checkout -b my-new-feature)
  3. Commit your changes (git commit -am 'Add some feature')
  4. Push to the branch (git push origin my-new-feature)
  5. Create a new Pull Request