ruby-octokit-client

  • Build Status
  • Requires:
    • Ruby
    • Tested using 2.0.0 and 2.1.5.
    • Rake
    • Bundle
    • Some other libs, but bundle installs them.
  • Installion:
    $ git clone --depth=50 --branch=master https://github.com/supertassu/ruby-octocat-client.git supertassu/ruby-octocat-client Cloning into 'supertassu/ruby-octocat-client'... remote: Counting objects: 55, done. remote: Compressing objects: 100% (40/40), done. remote: Total 55 (delta 23), reused 30 (delta 12), pack-reused 0 Unpacking objects: 100% (55/55), done. Checking connectivity... done. $ cd supertassu/ruby-octocat-client $ bundle install Fetching gem metadata from https://rubygems.org/.......... Fetching additional metadata from https://rubygems.org/.. Resolving dependencies... Installing addressable 2.3.8 Installing multipart-post 2.0.0 Installing faraday 0.9.2 Installing highline 1.7.8 Installing sawyer 0.6.0 Installing octokit 4.2.0 Using bundler 1.7.6 Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.
  • Test: $ rake test TEST > Starting test... done
  • Run: $ rake ---- Supertassu