Ruby-China

This is the source code of Ruby China website.

Build
Status

Install

  • You need Ruby 1.9.2+, Rubygems and Rails 3.2+ first.
  • Install and start Redis, MongoDB, memcached, Python, Pygments

and run:

easy_install pygments # 或者 pip install pygments
cp config/config.yml.default config/config.yml
cp config/mongoid.yml.default config/mongoid.yml
cp config/redis.yml.default config/redis.yml
cp config/thin.yml.default config/thin.yml
bundle install
bundle exec rake db:migrate
bundle exec rake db:seed
bundle exec sidekiq -c config/sidekiq.yml
bundle exec rake sunspot:solr:start
rails s

or you can just this issue

bundle exec rspec spec

to prepare all the config files and start essential services.

Deploy

$ cap deploy
$ cap production remote_rake:invoke task=db:setup

Apply Google JSAPI

Memcached

Dalli requires memcached 1.4.x +

Contributors

Thanks

Forked from Homeland Project

License

Copyright (c) 2011-2012 Ruby China

Released under the MIT license: