logger.rb - simple logging utility

version 1.2.8

CAUTION

logger is bundled with ruby/1.8 and 1.9 so when you simply do
'require "logger"' in your lib/app, stock logger.rb is used. You need to
declare to use the gem version of logger by 'gem "logger"; require "logger"'
instead.

Document

See RDoc in lib/logger.rb. To get RDoc in html format, exec 'rake doc'.

Changes

1.2.8 - 2011-05-14
  * gemified

Development Repository

https://github.com/nahi/logger

Author

NAKAMURA, Hiroshi a.k.a. NaHi
nahi@ruby-lang.org

Documentation: Gavin Sinclair

Legal notice

This program is copyrighted free software by NAKAMURA, Hiroshi.  You can
redistribute it and/or modify it under the same terms of Ruby's license;
either the dual license version in 2003, or any later version.