Mongo Kerberos Build Status Code Climate Coverage Status

Provides Kerberos authentication support to the Mongo Ruby Driver.


mongo_kerberos is tested against MRI (1.9.2+) and JRuby (1.7.0+)


libsasl is a requirement to be able to install the mongo_kerberos gem. Please see the Cyrus documentation for more information.

With bundler, add the mongo_kerberos gem to your Gemfile.

gem "mongo_kerberos", "~> 2.0"

Require the mongo_kerberos gem in your application.

require "mongo_kerberos"


API Documentation

The API Documentation is located at


As of 2.0.0, this project adheres to the Semantic Versioning Specification.