ExecPHP

Gem Version Build Status Dependency Status Coverage Status

ExecPHP is a ruby library (gem) that lets you run PHP code bundles on your remote servers. You need to have up and running Apache/Nginx/IIS server with mod_php enabled in order to run your PHP code there.

Requirements

Client-side: * Ruby 2.0.0 and above

Server-side: * Apache/Nginx/IIS * PHP4, PHP5 and above

Installation

Add this line to your application's Gemfile:

gem 'execphp'

And then execute:

$ bundle install

Or install it yourself as:

$ gem install execphp

Usage

Coming soon...

Contributing

Contributions are very welcome!

  1. Fork it
  2. Create your feature branch (git checkout -b my-new-feature)
  3. Commit your changes (git commit -am 'Add some feature')
  4. Push to the branch (git push origin my-new-feature)
  5. Create new Pull Request

License

Released under the MIT License. See the LICENSE file for further details.