minitest-activemodel

Build Status Dependency Status Code Climate

MiniTest matchers for ActiveModel::Validations.

Support

This gem supports:

  • Ruby 1.9.3, 2.0.0, ruby-head, rbx-19mode.
  • ActiveModel 3.2.x.

Installation

Add this line to your application's Gemfile:

gem 'minitest-activemodel', group: :test

And then execute:

$ bundle

Or install it yourself as:

$ gem install minitest-activemodel

Then, you have to include the matchers into TestCase

class MiniTest::Unit::TestCase
  include MiniTest::Matchers::ActiveModel
end

Usage

Check the official documentation for more details.

Contributing

Read CONTRIBUTING.

License

MIT License. Copyright 2012 Francesco Rodriguez. See LICENSE.md for more information.