Savvy Cert

Build Status Gem Version Depfu Maintainability Test Coverage

Savvy Cert is a ruby gem to help encrypt OAuth client secrets so that they can be safely stored in desktop applications. This gem is a work in progress and is a smaller part of a larger planned suite of software to assist in OAuth related desktop problems.

Documentation

You should find the documentation for your version of savvy-cert on Rubygems

See GETTING_STARTED for information on how to generate and read encrypted certificates.

Installation

Add this line to your application's Gemfile:

gem 'savvy-cert'

And then execute:

bundle

Or install it yourself as:

gem install savvy-cert

Supported Ruby version

Savvy-Cert supports ruby 2.4.0+

Development

After checking out the repo, run bin/setup to install dependencies. You can also run bin/console for an interactive prompt that will allow you to experiment.

To install this gem onto your local machine, run bundle exec rake install.

License

The gem is available as open source under the terms of the MIT License.

Code of Conduct

Everyone interacting in the Savvy Cert project’s codebases, issue trackers, chat rooms and mailing lists is expected to follow the code of conduct.