rOCCI-core - A Ruby OCCI Framework

Travis Gemnasium Gem Code Climate

Requirements

Ruby

  • Ruby 2.2.2 is required
  • Rubygems

Installation

As a gem

To install the most recent stable version

gem install occi-core

To install the most recent beta version

gem install occi-core --pre

From source

To build and install the bleeding edge version from master

gem install bundler
git clone git://github.com/EGI-FCTF/rOCCI-core.git
cd rOCCI-core
gem build occi-core.gemspec

Usage

Detailed documentation is available in our wiki.

Changelog

See CHANGELOG.md.

Code Documentation

Code Documentation for rOCCI

Contribute

  1. Fork it.
  2. Create a branch (git checkout -b my_markup)
  3. Commit your changes (git commit -am "My changes")
  4. Push to the branch (git push origin my_markup)
  5. Create an Issue with a link to your branch