Filterrific

Filterrific is a Rails Engine plugin that makes it easy to add filtering, searching, and sorting to your ActiveRecord lists.

Make sure to go to the fantastic Filterrific documentation to find out more!

TODO: look at Jeff's email suggestions (June 23, 2014)

Installation

gem install filterrific

or with bundler in your Gemfile:

gem 'filterrific'

Compatibility

Every commit to Filterrific is automatically tested against the following scenarios:

Rails version Ruby environments Database adapters Build status
Rails 4.1 MRI 1.9.3, 2.0.0, 2.1.2 mysql, mysql2, postgresql, sqlite3 Build Status
Rails 4.0 MRI 1.9.3, 2.0.0, 2.1.2 mysql, mysql2, postgresql, sqlite3 Build Status
Rails 3.2 MRI 1.9.3, 2.0.0, 2.1.2 mysql, mysql2, postgresql, sqlite3 Build Status

Filterrific version 1.4.0 should work on older versions of Rails and Ruby, however the 1.x branch is not supported any more.

Guidelines for submitting issues

I'm happy to help you if you encounter problems when using filterrific. You'll make my job easier if you follow these guidelines:

  • Please keep in mind that I do this in my spare time. I appreciate it if you first do everything you can on your own: read the detailed filterrific documentation, look for similar issues on StackOverflow, search the internets, etc.
  • If you're stuck, give me sufficient context so that I have a chance to identify the issue:
    • what version of filterrific are you using? (look in your Gemfile.lock)
    • what version of Rails are you using? (look in your Gemfile.lock)
    • what version of Ruby are you using? (run ruby -v in your app root)
  • If you get an exception, include the entire stack trace, including the error message.
  • Include any relevant code snippets (your model, controller, and view code).

Resources

Build Status

Code Climate

License

MIT licensed.

Copyright

Copyright (c) 2010 - 2014 Jo Hund. See (MIT) LICENSE for details.