Class: Chef::Provider::Package::Solaris

Inherits:
Chef::Provider::Package show all
Includes:
Mixin::GetSourceFromPackage
Defined in:
lib/chef/provider/package/solaris.rb

Instance Attribute Summary

Attributes inherited from Chef::Provider

#current_resource, #new_resource, #run_context

Instance Method Summary collapse

Methods included from Mixin::GetSourceFromPackage

#initialize

Methods inherited from Chef::Provider::Package

#action_install, #action_purge, #action_reconfig, #action_remove, #action_upgrade, #expand_options, #get_preseed_file, #initialize, #preseed_package, #preseed_resource, #purge_package, #reconfig_package, #removing_package?, #upgrade_package

Methods included from Mixin::Command

#chdir_or_tmpdir, #handle_command_failures, #output_of_command, #run_command, #run_command_with_systems_locale

Methods included from Mixin::Command::Windows

#popen4

Methods included from Mixin::Command::Unix

#popen4

Methods inherited from Chef::Provider

#action_nothing, build_from_file, #cookbook_name, #initialize, #node, #resource_collection

Methods included from Mixin::ConvertToClassName

#convert_to_class_name, #convert_to_snake_case, #filename_to_qualified_string, #snake_case_basename

Methods included from Mixin::RecipeDefinitionDSLCore

#method_missing

Methods included from Mixin::Language

#data_bag, #data_bag_item, #platform?, #search, #value_for_platform

Dynamic Method Handling

This class handles dynamic methods through the method_missing method in the class Chef::Mixin::RecipeDefinitionDSLCore

Instance Method Details

#candidate_versionObject



80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
# File 'lib/chef/provider/package/solaris.rb', line 80

def candidate_version
  return @candidate_version if @candidate_version
  status = popen4("pkginfo -l -d #{@new_resource.source} #{new_resource.package_name}") do |pid, stdin, stdout, stderr|
    stdout.each_line do |line|
      case line
      when /VERSION:\s+(.+)/
        @candidate_version = $1
        @new_resource.version($1)
        Chef::Log.debug("#{@new_resource} setting install candidate version to #{@candidate_version}")
      end
    end
  end
  unless status.exitstatus == 0
    raise Chef::Exceptions::Package, "pkginfo -l -d #{@new_resource.source} - #{status.inspect}!"
  end
  @candidate_version
end

#install_package(name, version) ⇒ Object



98
99
100
101
102
103
104
105
106
107
108
109
110
111
# File 'lib/chef/provider/package/solaris.rb', line 98

def install_package(name, version)
  Chef::Log.debug("#{@new_resource} package install options: #{@new_resource.options}")
  if @new_resource.options.nil?
    run_command_with_systems_locale(
            :command => "pkgadd -n -d #{@new_resource.source} all"
          )
    Chef::Log.debug("#{@new_resource} installed version #{@new_resource.version} from: #{@new_resource.source}")
  else
    run_command_with_systems_locale(
      :command => "pkgadd -n#{expand_options(@new_resource.options)} -d #{@new_resource.source} all"
    )
    Chef::Log.debug("#{@new_resource} installed version #{@new_resource.version} from: #{@new_resource.source}")
  end
end

#load_current_resourceObject

def initialize(*args)

super
@current_resource = Chef::Resource::Package.new(@new_resource.name)

end



35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
# File 'lib/chef/provider/package/solaris.rb', line 35

def load_current_resource
  @current_resource = Chef::Resource::Package.new(@new_resource.name)
  @current_resource.package_name(@new_resource.package_name)
  @new_resource.version(nil)

  if @new_resource.source
    unless ::File.exists?(@new_resource.source)
      raise Chef::Exceptions::Package, "Package #{@new_resource.name} not found: #{@new_resource.source}"
    end

    Chef::Log.debug("#{@new_resource} checking pkg status")
    status = popen4("pkginfo -l -d #{@new_resource.source} #{@new_resource.package_name}") do |pid, stdin, stdout, stderr|
      stdout.each do |line|
        case line
        when /VERSION:\s+(.+)/
          @new_resource.version($1)
        end
      end
    end
  elsif Array(@new_resource.action).include?(:install)
    raise Chef::Exceptions::Package, "Source for package #{@new_resource.name} required for action install"
  end

  Chef::Log.debug("#{@new_resource} checking install state")
  status = popen4("pkginfo -l #{@current_resource.package_name}") do |pid, stdin, stdout, stderr|
    stdout.each do |line|
      case line
      when /VERSION:\s+(.+)/
        Chef::Log.debug("#{@new_resource} version #{$1} is already installed")
        @current_resource.version($1)
      end
    end
  end

  unless status.exitstatus == 0 || status.exitstatus == 1
    raise Chef::Exceptions::Package, "pkginfo failed - #{status.inspect}!"
  end

  unless @current_resource.version.nil?
    @current_resource.version(nil)
  end

  @current_resource
end

#remove_package(name, version) ⇒ Object



113
114
115
116
117
118
119
120
121
122
123
124
125
# File 'lib/chef/provider/package/solaris.rb', line 113

def remove_package(name, version)
  if @new_resource.options.nil?
    run_command_with_systems_locale(
            :command => "pkgrm -n #{name}"
          )
    Chef::Log.debug("#{@new_resource} removed version #{@new_resource.version}")
  else
    run_command_with_systems_locale(
      :command => "pkgrm -n#{expand_options(@new_resource.options)} #{name}"
    )
    Chef::Log.debug("#{@new_resource} removed version #{@new_resource.version}")
  end
end